№19
Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат 
две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один 
ход игрок может убрать из одной из куч один камень или уменьшить 
количество камней в куче в два раза (если количество камней в куче нечётно, 
остаётся на 1 камень больше, чем убирается). Например, пусть в одной куче 
6, а в другой 9 камней; такую позицию мы будем обозначать (6, 9). За один 
ход из позиции (6, 9) можно получить любую из четырёх позиций: (5, 9), (3, 
9), (6, 8), (6, 5). Игра завершается в тот момент, когда суммарное количество 
камней в кучах становится не более 32. Победителем считается игрок, 
сделавший последний ход, то есть первым получивший позицию, в которой 
в кучах будет 32 или меньше камней. В начальный момент в первой куче 
было 10 камней, во второй куче – S камней, S > 22.
Найдите значение S, при котором Ваня выигрывает своим первым ходом при 
любой игре Пети.
Ответ: 48.
def f(s1,s2,c,m):
    if s1+s2<=32: return c%2 == m%2
    if c==m: return 0

    h = []
    h.append(f(s1-1,s2,c+1,m))
    h.append(f(s1, s2-1, c + 1, m))
    if s1%2 == 0:
        h.append(f(s1//2, s2, c + 1, m))
    elif s1%2==0: h.append(f(s1//2+1, s2, c + 1, m))

    if s2 % 2 == 0:
        h.append(f(s1, s2 //2, c + 1, m))
    elif s2%2==1:
        h.append(f(s1, (s2//2) +1, c + 1, m))

    return any(h) if (c+1)%2 == m%2 else all(h)

for s2 in range(23,100):
    for m in range(1,5):
        if f(10,s2,0,m):
            if m==2 or m==4:
                print(10,s2,m)
                #break
    print()

-------------------------------------------------------

№20
Для игры, описанной в задании 19, найдите минимальное и максимальное 
значение S, при котором у Пети есть выигрышная стратегия, причём 
одновременно выполняются два условия:
− Петя не может выиграть за один ход;
− Петя может выиграть своим вторым ходом независимо от того, как будет 
ходить Ваня.
Найденные значения запишите в ответе в порядке возрастания
Ответ: 4690

def f(s1,s2,c,m):
    if s1+s2<=32: return c%2 == m%2
    if c==m: return 0

    h = []
    h.append(f(s1-1,s2,c+1,m))
    h.append(f(s1, s2-1, c + 1, m))
    if s1%2 == 0:
        h.append(f(s1//2, s2, c + 1, m))
    elif s1%2==0: h.append(f(s1//2+1, s2, c + 1, m))

    if s2 % 2 == 0:
        h.append(f(s1, s2 //2, c + 1, m))
    elif s2%2==1:
        h.append(f(s1, (s2//2) +1, c + 1, m))

    return any(h) if (c+1)%2 == m%2 else all(h)

for s2 in range(23,100):
    for m in range(1,5):
        if f(10,s2,0,m):
            if m==1 or m==3:
                print(10,s2,m)
                #break
    print()
-------------------------------------------------------------------

№21
Для игры, описанной в задании 19, найдите значение S, при котором 
одновременно выполняются два условия:
– у Вани есть выигрышная стратегия, позволяющая ему выиграть первым 
или вторым ходом при любой игре Пети;
– у Вани нет стратегии, которая позволит ему гарантированно выиграть 
первым ходом.
Ответ: 48

#
def f(s1,s2,c,m):
    if s1+s2<=32: return c%2 == m%2
    if c==m: return 0

    h = []
    h.append(f(s1-1,s2,c+1,m))
    h.append(f(s1, s2-1, c + 1, m))
    if s1%2 == 0:
        h.append(f(s1//2, s2, c + 1, m))
    elif s1%2==0: h.append(f(s1//2+1, s2, c + 1, m))

    if s2 % 2 == 0:
        h.append(f(s1, s2 //2, c + 1, m))
    elif s2%2==1:
        h.append(f(s1, (s2//2) +1, c + 1, m))

    return any(h) if (c+1)%2 == m%2 else all(h)

for s2 in range(23,100):
    for m in range(1,5):
        if f(10,s2,0,m):
            if m==2 or m==4:
                print(10,s2,m)
                #break
    print()
